Your requirements could not be resolved to an installable set of packages.

安装报错 · ionecc · 于 2年前 发布 · 751 次阅读
➜  fecshop-1.7.3.0 composer update                                                                               
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - fancyecommerce/fecshop 1.7.4.0 requires ext-mongodb * -> the requested PHP extension mongodb is missing from your system.
    - fancyecommerce/fecshop 1.7.3.0 requires ext-mongodb * -> the requested PHP extension mongodb is missing from your system.
    - fancyecommerce/fecshop 1.7.2.0 requires ext-mongodb * -> the requested PHP extension mongodb is missing from your system.
    - fancyecommerce/fecshop 1.7.1.0 requires ext-mongodb * -> the requested PHP extension mongodb is missing from your system.
    - fancyecommerce/fecshop 1.7.0.0 requires ext-mongodb * -> the requested PHP extension mongodb is missing from your system.
    - fancyecommerce/fecshop 1.7.4.0 requires ext-mongodb * -> the requested PHP extension mongodb is missing from your system.
    - Installation request for fancyecommerce/fecshop ^1.7 -> satisfiable by fancyecommerce/fecshop[1.7.0.0, 1.7.1.0, 1.7.2.0, 1.7.3.0, 1.7.4.0].

  To enable extensions, verify that they are enabled in your .ini files:
    - /Applications/MAMP/bin/php/php7.1.26/conf/php.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

共收到 2 条回复
Fecmall#12年前 0 个赞

the requested PHP extension mongodb is missing from your system

出现报错自己先看一下报错内容,翻译一下就明白了,缺少php-mongodb扩展

Fecmall#22年前 0 个赞

另外这个报错在论坛可以搜索相关帖子,先搜帖子解决问题。

添加回复 (需要登录)
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册
Your Site Analytics